TEMP-0000000-59D7FF

NameTEMP-0000000-59D7FF
DescriptionAV1 codec parser buffer overflow
SourceAutomatically generated temporary name. Not for external reference.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gst-plugins-bad1.0 (PTS)buster1.14.4-1+deb10u2fixed
buster (security)1.14.4-1+deb10u5fixed
bullseye (security), bullseye1.18.4-3+deb11u4fixed
bookworm, bookworm (security)1.22.0-4+deb12u5fixed
trixie, sid1.22.10-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gst-plugins-bad0.10source(unstable)(not affected)
gst-plugins-bad1.0sourcebuster(not affected)
gst-plugins-bad1.0sourcebullseye(not affected)
gst-plugins-bad1.0sourcebookworm1.22.0-4+deb12u4
gst-plugins-bad1.0source(unstable)1.22.8-1

Notes

[bullseye] - gst-plugins-bad1.0 <not-affected> (Vulnerable code not present)
[buster] - gst-plugins-bad1.0 <not-affected> (Vulnerable code not present)
- gst-plugins-bad0.10 <not-affected> (Vulnerable code not present)
https://gstreamer.freedesktop.org/security/sa-2023-0011.html
https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/5823
Fixed by: https://gitlab.freedesktop.org/gstreamer/gstreamer/-/commit/890d59e97e291fe848147ebf4d5884bcec1101c9
Fixed by: https://gitlab.freedesktop.org/gstreamer/gstreamer/-/commit/a46737a73155fe1c19fa5115df40da35426f9fb5 (1.22.8)

Search for package or bug name: Reporting problems