CVE-2000-1219

NameCVE-2000-1219
DescriptionThe -ftrapv compiler option in gcc and g++ 3.3.3 and earlier does not handle all types of integer overflows, which may leave applications vulnerable to vulnerabilities related to overflows.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gcc-3.3 (PTS)jessie1:3.3.6ds1-27.2fixed
stretch1:3.3.6ds1-28fixed
bullseye, sid, buster1:3.3.6ds1-30fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gcc-3.3source(unstable)1:3.3.4-1high

Search for package or bug name: Reporting problems