CVE-2001-1494

NameCVE-2001-1494
Descriptionscript command in the util-linux package before 2.11n allows local users to overwrite arbitrary files by setting a hardlink from the typescript log file to any file on the system, then having root execute the script command.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
util-linux (PTS)buster2.33.1-0.1fixed
buster (security)2.33.1-0.1+deb10u1fixed
bullseye2.36.1-8+deb11u1fixed
bullseye (security)2.36.1-8+deb11u2fixed
bookworm2.38.1-5fixed
bookworm (security)2.38.1-5+deb12u1fixed
trixie2.39.3-6fixed
sid2.40-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
util-linuxsource(unstable)2.11n-1

Search for package or bug name: Reporting problems