CVE-2002-0639

NameCVE-2002-0639
DescriptionInteger overflow in sshd in OpenSSH 2.9.9 through 3.3 allows remote attackers to execute arbitrary code during challenge response authentication (ChallengeResponseAuthentication) when OpenSSH is using SKEY or BSD_AUTH authentication.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssh (PTS)squeeze, squeeze (security)1:5.5p1-6+squeeze5fixed
squeeze (lts)1:5.5p1-6+squeeze6fixed
wheezy1:6.0p1-4+deb7u2fixed
wheezy (security)1:6.0p1-4+deb7u1fixed
jessie1:6.7p1-5fixed
stretch, sid1:6.9p1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensshsource(unstable)1:3.4high

Search for package or bug name: Reporting problems