CVE-2002-0656

NameCVE-2002-0656
DescriptionBuffer overflows in OpenSSL 0.9.6d and earlier, and 0.9.7-beta2 and earlier, allow remote attackers to execute arbitrary code via (1) a large client master key in SSL2 or (2) a large session ID in SSL3.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-136
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssl (PTS)stretch1.1.0l-1~deb9u1fixed
stretch (security)1.1.0l-1~deb9u3fixed
buster1.1.1d-0+deb10u5fixed
buster (security)1.1.1d-0+deb10u6fixed
bullseye, sid1.1.1k-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensslsourcewoody0.9.6c-2.woody.1DSA-136
opensslsource(unstable)0.9.6e-1
openssl094sourcewoody0.9.4-6.woody.2DSA-136
openssl095sourcewoody0.9.5a-6.woody.1DSA-136

Search for package or bug name: Reporting problems