CVE-2002-0728

NameCVE-2002-0728
DescriptionBuffer overflow in the progressive reader for libpng 1.2.x before 1.2.4, and 1.0.x before 1.0.14, allows attackers to cause a denial of service (crash) via a PNG data stream that has more IDAT data than indicated by the IHDR chunk.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-140
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libpng (PTS)wheezy, wheezy (security)1.2.49-1+deb7u2fixed
jessie1.2.50-2+deb8u3fixed
jessie (security)1.2.50-2+deb8u2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libpngsource(unstable)1.0.12-4medium
libpngsourcewoody1.0.12-3.woody.2mediumDSA-140
libpng3source(unstable)1.2.1-2medium
libpng3sourcewoody1.2.1-1.1.woody.2mediumDSA-140

Search for package or bug name: Reporting problems