CVE-2002-0840

NameCVE-2002-0840
DescriptionCross-site scripting (XSS) vulnerability in the default error page of Apache 2.0 before 2.0.43, and 1.3.x up to 1.3.26, when UseCanonicalName is "Off" and support for wildcard DNS is present, allows remote attackers to execute script as other web page visitors via the Host: header, a different vulnerability than CAN-2002-1157.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-187, DSA-188, DSA-195

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)buster2.4.38-3+deb10u8fixed
buster (security)2.4.38-3+deb10u7fixed
bullseye2.4.54-1~deb11u1fixed
bullseye (security)2.4.52-1~deb11u2fixed
bookworm2.4.54-3fixed
sid2.4.54-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apachesourcewoody1.3.26-0woodyDSA-187
apachesource(unstable)1.3.27-0.1
apache-perlsourcewoody1.3.26-1-1.26-0woody2DSA-195
apache-perlsource(unstable)1.3.26-1.1-1.27-3-1
apache-sslsourcewoody1.3.26.1+1.48-0woody3DSA-188
apache2source(unstable)2.0.43-1

Search for package or bug name: Reporting problems