CVE-2002-0847

NameCVE-2002-0847
Descriptiontinyproxy HTTP proxy 1.5.0, 1.4.3, and earlier allows remote attackers to execute arbitrary code via memory that is freed twice (double-free).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-145
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tinyproxy (PTS)wheezy, jessie1.8.3-3fixed
stretch1.8.4-2fixed
buster, sid1.8.4-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tinyproxysource(unstable)1.4.3-3high
tinyproxysourcewoody1.4.3-2woody2highDSA-145

Search for package or bug name: Reporting problems