CVE-2002-1174

NameCVE-2002-1174
DescriptionBuffer overflows in Fetchmail 6.0.0 and earlier allow remote attackers to cause a denial of service (crash) or execute arbitrary code via (1) long headers that are not properly processed by the readheaders function, or (2) via long Received: headers, which are not properly parsed by the parse_received function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-171
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
fetchmail (PTS)wheezy6.3.21-4fixed
jessie6.3.26-1fixed
stretch, sid6.3.26-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
fetchmailsource(unstable)6.1.0-1high
fetchmailsourcewoody5.9.11-6.1highDSA-171
fetchmail-sslsourcewoody5.9.11-6.1highDSA-171

Search for package or bug name: Reporting problems