CVE-2002-1235

NameCVE-2002-1235
DescriptionThe kadm_ser_in function in (1) the Kerberos v4compatibility administration daemon (kadmind4) in the MIT Kerberos 5 (krb5) krb5-1.2.6 and earlier, (2) kadmind in KTH Kerberos 4 (eBones) before 1.2.1, and (3) kadmind in KTH Kerberos 5 (Heimdal) before 0.5.1 when compiled with Kerberos 4 support, does not properly verify the length field of a request, which allows remote attackers to execute arbitrary code via a buffer overflow attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-183, DSA-184, DSA-185
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
heimdal (PTS)wheezy1.6~git20120403+dfsg1-2fixed
wheezy (security)1.6~git20120403+dfsg1-2+deb7u1fixed
jessie (security), jessie1.6~rc2+dfsg-9+deb8u1fixed
stretch7.1.0+dfsg-13+deb9u1fixed
stretch (security)7.1.0+dfsg-13+deb9u2fixed
buster, sid7.4.0.dfsg.1-2fixed
krb5 (PTS)wheezy1.10.1+dfsg-5+deb7u7fixed
wheezy (security)1.10.1+dfsg-5+deb7u8fixed
jessie1.12.1+dfsg-19+deb8u4fixed
jessie (security)1.12.1+dfsg-19+deb8u2fixed
stretch1.15-1+deb9u1fixed
buster, sid1.15.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
heimdalsource(unstable)0.4e-22high
heimdalsourcewoody0.4e-7.woody.5highDSA-185
krb4source(unstable)1.1-11-8high
krb4sourcewoody1.1-8-2.2highDSA-184
krb5source(unstable)1.2.6-2high
krb5sourcewoody1.2.4-5woody3highDSA-183

Search for package or bug name: Reporting problems