CVE-2002-1391

NameCVE-2002-1391
DescriptionBuffer overflow in cnd-program for mgetty before 1.1.29 allows remote attackers to cause a denial of service and possibly execute arbitrary code via a Caller ID string with a long CallerName argument.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mgetty (PTS)stretch (security), stretch1.1.36-3+deb9u1fixed
buster1.2.1-1fixed
bookworm, sid, bullseye1.2.1-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mgettysource(unstable)1.1.30-1

Notes

woody version seems to be vulnerable see bug #199351

Search for package or bug name: Reporting problems