CVE-2002-1565

NameCVE-2002-1565
DescriptionBuffer overflow in url_filename function for wget 1.8.1 allows attackers to cause a denial of service (segmentation fault) and possibly execute arbitrary code via a long URL.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wget (PTS)wheezy1.13.4-3+deb7u2fixed
wheezy (security)1.13.4-3+deb7u5fixed
jessie (security), jessie1.16-1+deb8u4fixed
stretch (security), stretch1.18-5+deb9u1fixed
buster, sid1.19.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wgetsource(unstable)1.8.2-8high

Search for package or bug name: Reporting problems