CVE-2002-2443

NameCVE-2002-2443
Descriptionschpw.c in the kpasswd service in kadmind in MIT Kerberos 5 (aka krb5) before 1.11.3 does not properly validate UDP packets before sending responses, which allows remote attackers to cause a denial of service (CPU and bandwidth consumption) via a forged packet that triggers a communication loop, as demonstrated by krb_pingpong.nasl, a related issue to CVE-1999-0103.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2701-1
NVD severitymedium (attack range: remote)
Debian Bugs708267
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
krb5 (PTS)squeeze, squeeze (security)1.8.3+dfsg-4squeeze7fixed
squeeze (lts)1.8.3+dfsg-4squeeze9fixed
wheezy1.10.1+dfsg-5+deb7u2fixed
wheezy (security)1.10.1+dfsg-5+deb7u3fixed
jessie1.12.1+dfsg-19fixed
stretch, sid1.13.2+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
krb5source(unstable)1.10.1+dfsg-6medium708267
krb5sourcesqueeze1.8.3+dfsg-4squeeze7mediumDSA-2701-1
krb5sourcewheezy1.10.1+dfsg-5+deb7u1mediumDSA-2701-1

Notes

http://krbdev.mit.edu/rt/Ticket/Display.html?id=7637
https://github.com/krb5/krb5/commit/cf1a0c411b2668c57c41e9c4efd15ba17b6b322c

Search for package or bug name: Reporting problems