CVE-2003-0031

NameCVE-2003-0031
DescriptionMultiple buffer overflows in libmcrypt before 2.5.5 allow attackers to cause a denial of service (crash).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-228
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libmcrypt (PTS)wheezy2.5.8-3.1fixed
buster, sid, jessie, stretch2.5.8-3.3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libmcryptsource(unstable)2.5.5-1high
libmcryptsourcewoody2.5.0-1woody1highDSA-228

Search for package or bug name: Reporting problems