CVE-2003-0040

NameCVE-2003-0040
DescriptionSQL injection vulnerability in the PostgreSQL auth module for courier 0.40 and earlier allows remote attackers to execute SQL code via the user name.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-247
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
courier (PTS)wheezy0.68.2-1fixed
jessie0.73.1-1.6fixed
stretch0.76.3-5fixed
sid0.78.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
couriersource(unstable)0.40.2-3high
couriersourcewoody0.37.3-3.3highDSA-247
courier-sslsource(unstable)0.40.2-3high

Search for package or bug name: Reporting problems