CVE-2003-0138

NameCVE-2003-0138
DescriptionVersion 4 of the Kerberos protocol (krb4), as used in Heimdal and other packages, allows an attacker to impersonate any principal in a realm via a chosen-plaintext attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-266, DSA-269, DSA-273
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
heimdal (PTS)wheezy1.6~git20120403+dfsg1-2fixed
wheezy (security)1.6~git20120403+dfsg1-2+deb7u1fixed
jessie (security), jessie1.6~rc2+dfsg-9+deb8u1fixed
stretch (security), stretch7.1.0+dfsg-13+deb9u1fixed
buster, sid7.4.0.dfsg.1-2fixed
krb5 (PTS)wheezy1.10.1+dfsg-5+deb7u7fixed
wheezy (security)1.10.1+dfsg-5+deb7u8fixed
jessie (security), jessie1.12.1+dfsg-19+deb8u2fixed
stretch1.15-1+deb9u1fixed
buster, sid1.15.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
heimdalsource(unstable)0.5.2-1high
heimdalsourcewoody0.4e-7.woody.8highDSA-269
krb4source(unstable)1.2.2-1high
krb4sourcewoody1.1-8-2.3highDSA-273
krb5source(unstable)1.2.7-3high
krb5sourcewoody1.2.4-5woody4highDSA-266

Search for package or bug name: Reporting problems