CVE-2003-0167

NameCVE-2003-0167
DescriptionMultiple off-by-one buffer overflows in the IMAP capability for Mutt 1.3.28 and earlier, and Balsa 1.2.4 and earlier, allow a remote malicious IMAP server to cause a denial of service (crash) and possibly execute arbitrary code via a specially crafted mail folder, a different vulnerability than CVE-2003-0140.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-274, DSA-300
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
balsa (PTS)wheezy, jessie2.4.12-1fixed
stretch2.4.12-3fixed
buster, sid2.5.3-2fixed
mutt (PTS)wheezy, wheezy (security)1.5.21-6.2+deb7u3fixed
jessie1.5.23-3fixed
stretch1.7.2-1fixed
buster, sid1.8.3+neomutt20170609-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
balsasource(unstable)2.0.10high
balsasourcewoody1.2.4-2.2highDSA-300
muttsource(unstable)1.4.0high
muttsourcewoody1.3.28-2.2highDSA-274

Search for package or bug name: Reporting problems