CVE-2003-0380

NameCVE-2003-0380
DescriptionBuffer overflow in atftp daemon (atftpd) 0.6.1 and earlier, and possibly later versions, allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long filename.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-314
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
atftp (PTS)wheezy0.7.dfsg-11fixed
jessie0.7.git20120829-1fixed
buster, sid, stretch0.7.git20120829-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
atftpsource(unstable)0.6.2high
atftpsourcewoody0.6.1.1.0woody1highDSA-314

Search for package or bug name: Reporting problems