CVE-2003-0427

NameCVE-2003-0427
DescriptionBuffer overflow in mikmod 3.1.6 and earlier allows remote attackers to execute arbitrary code via an archive file that contains a file with a long filename.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-320
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mikmod (PTS)wheezy3.2.1-4fixed
jessie3.2.6-1fixed
stretch3.2.7-1fixed
buster, sid3.2.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mikmodsource(unstable)3.1.6-6high
mikmodsourcewoody3.1.6-4woody3highDSA-320

Search for package or bug name: Reporting problems