CVE-2003-0545

NameCVE-2003-0545
DescriptionDouble free vulnerability in OpenSSL 0.9.7 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via an SSL client certificate with a certain invalid ASN.1 encoding.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-393, DSA-394
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssl (PTS)jessie1.0.1t-1+deb8u8fixed
jessie (security)1.0.1t-1+deb8u12fixed
stretch1.1.0k-1~deb9u1fixed
stretch (security)1.1.0l-1~deb9u1fixed
buster, buster (security)1.1.1d-0+deb10u2fixed
bullseye, sid1.1.1d-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensslsource(unstable)0.9.7c
opensslsourcewoody0.9.6c-2.woody.4DSA-393
openssl095sourcewoody0.9.5a-6.woody.3DSA-394
openssl096source(unstable)0.9.6k

Search for package or bug name: Reporting problems