CVE-2003-0690

NameCVE-2003-0690
DescriptionKDM in KDE 3.1.3 and earlier does not verify whether the pam_setcred function call succeeds, which may allow attackers to gain root privileges by triggering error conditions within PAM modules, as demonstrated in certain configurations of the MIT pam_krb5 module.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-388, DSA-443
NVD severityhigh (attack range: remote)

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kdebasesource(unstable)4:3.2high
kdebasesourcewoody4:2.2.2-14.7highDSA-388
xfree86source(unstable)4.3.0-0pre1v2high
xfree86sourcewoody4.1.0-16woody3highDSA-443

Search for package or bug name: Reporting problems