CVE-2003-0693

NameCVE-2003-0693
DescriptionA "buffer management error" in buffer_append_space of buffer.c for OpenSSH before 3.7 may allow remote attackers to execute arbitrary code by causing an incorrect amount of memory to be freed and corrupting the heap, a different vulnerability than CVE-2003-0695.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-382, DSA-383
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssh (PTS)wheezy1:6.0p1-4+deb7u4fixed
wheezy (security)1:6.0p1-4+deb7u6fixed
jessie (security), jessie1:6.7p1-5+deb8u3fixed
stretch1:7.4p1-10+deb9u1fixed
buster, sid1:7.6p1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensshsource(unstable)1:3.6.1p2-6.0high
opensshsourcewoody1:3.4p1-1.woody.3highDSA-382
openssh-krb5sourcewoody3.4p1-0woody4highDSA-383

Search for package or bug name: Reporting problems