CVE-2003-0695

NameCVE-2003-0695
DescriptionMultiple "buffer management errors" in OpenSSH before 3.7.1 may allow attackers to cause a denial of service or execute arbitrary code using (1) buffer_init in buffer.c, (2) buffer_free in buffer.c, or (3) a separate function in channels.c, a different vulnerability than CVE-2003-0693.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-382, DSA-383
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssh (PTS)wheezy1:6.0p1-4+deb7u4fixed
wheezy (security)1:6.0p1-4+deb7u6fixed
jessie1:6.7p1-5+deb8u4fixed
jessie (security)1:6.7p1-5+deb8u3fixed
stretch1:7.4p1-10+deb9u2fixed
buster, sid1:7.6p1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensshsource(unstable)1:3.7.1high
opensshsourcewoody1:3.4p1-1.woody.3highDSA-382
openssh-krb5sourcewoody3.4p1-0woody4highDSA-383

Search for package or bug name: Reporting problems