CVE-2003-0850

NameCVE-2003-0850
DescriptionThe TCP reassembly functionality in libnids before 1.18 allows remote attackers to cause "memory corruption" and possibly execute arbitrary code via "overlarge TCP packets."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-410
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libnids (PTS)wheezy, jessie1.23-2fixed
stretch1.23-2.1fixed
buster, sid1.24-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libnidssource(unstable)1.18-1high
libnidssourcewoody1.16-3woody1highDSA-410

Search for package or bug name: Reporting problems