CVE-2003-0961

NameCVE-2003-0961
DescriptionInteger overflow in the do_brk function for the brk system call in Linux kernel 2.4.22 and earlier allows local users to gain root privileges.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-403, DSA-417, DSA-423, DSA-433, DSA-439, DSA-440, DSA-442, DSA-450, DSA-470, DSA-475
NVD severityhigh (attack range: local)
Debian/oldstablenot known to be vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kernel-image-2.4.16-lartsourcewoody2.4.16-20040204highDSA-439
kernel-image-2.4.16-netwindersourcewoody2.4.16-20040204highDSA-439
kernel-image-2.4.16-riscpcsourcewoody2.4.16-20040204highDSA-439
kernel-image-2.4.17-hppasourcewoody32.3highDSA-470
kernel-image-2.4.17-ia64sourcewoodykernel-image-2.4.17-ia64highDSA-423
kernel-image-2.4.17-s390sourcewoody2.4.17-2.woody.3highDSA-442
kernel-image-2.4.18-1-alphasourcewoody2.4.18-12highDSA-417
kernel-image-2.4.18-1-i386sourcewoody2.4.18-12highDSA-403
kernel-image-2.4.18-hppasourcewoody62.1highDSA-475
kernel-patch-2.4.16-armsourcewoody20040204highDSA-439
kernel-patch-2.4.17-apussourcewoody2.4.17-4highDSA-440
kernel-patch-2.4.17-mipssourcewoody2.4.17-0.020226.2.woody4highDSA-433
kernel-patch-2.4.17-s390sourcewoody0.0.20020816-0.woody.2highDSA-442
kernel-patch-2.4.18-powerpcsourcewoody2.4.18-1woody3highDSA-417
kernel-patch-2.4.19-mipssourcewoody2.4.19-4.woody1highDSA-450
kernel-source-2.4.17sourcewoody2.4.17-4highDSA-440
kernel-source-2.4.18sourcewoody2.4.18-14highDSA-403
kernel-source-2.4.19sourcewoody2.4.19-0.020911.1.woody3highDSA-450
kernel-source-2.4.27source(unstable)(not affected)

Notes

- kernel-source-2.4.27 <not-affected> (Fixed before initial upload; 2.4.23-pre7)

Search for package or bug name: Reporting problems