CVE-2004-0074

NameCVE-2004-0074
DescriptionMultiple buffer overflows in xsok 1.02 allows local users to gain privileges via (1) a long LANG environment variable, or (2) a long -xsokdir command line argument, a different vulnerability than CVE-2003-0949.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xsok (PTS)stretch1.02-17.1fixed
bullseye, buster, sid1.02-19fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xsoksource(unstable)(not affected)

Notes

- xsok <not-affected> (Not vulnerable. See bug #278777)

Search for package or bug name: Reporting problems