CVE-2004-0110

NameCVE-2004-0110
DescriptionBuffer overflow in the (1) nanohttp or (2) nanoftp modules in XMLSoft Libxml 2 (Libxml2) 2.6.0 through 2.6.5 allow remote attackers to execute arbitrary code via a long URL.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-455
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxml2 (PTS)wheezy2.8.0+dfsg1-7+wheezy5fixed
wheezy (security)2.8.0+dfsg1-7+wheezy10fixed
jessie2.9.1+dfsg1-5+deb8u4fixed
jessie (security)2.9.1+dfsg1-5+deb8u5fixed
stretch (security), stretch2.9.4+dfsg1-2.2+deb9u1fixed
buster, sid2.9.4+dfsg1-5.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxmlsource(unstable)1:1.8.17-5high
libxmlsourcewoody1.8.17-2woody1highDSA-455
libxml2source(unstable)2.6.6-1high
libxml2sourcewoody2.4.19-4woody1highDSA-455

Search for package or bug name: Reporting problems