CVE-2004-0175

NameCVE-2004-0175
DescriptionDirectory traversal vulnerability in scp for OpenSSH before 3.4p1 allows remote malicious servers to overwrite arbitrary files. NOTE: this may be a rediscovery of CVE-2000-0992.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesCVE-2000-0992
NVD severitymedium (attack range: remote)
Debian Bugs270770

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssh (PTS)jessie1:6.7p1-5+deb8u4fixed
jessie (security)1:6.7p1-5+deb8u8fixed
stretch1:7.4p1-10+deb9u7fixed
stretch (security)1:7.4p1-10+deb9u6fixed
buster1:7.9p1-10fixed
bullseye, sid1:8.0p1-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensshsource(unstable)1:3.9p1-1low270770

Notes

[sarge] - openssh <no-dsa> (Minor issue)
The directory traversal part has been fixed in OpenSSH 3.9p1.
The "SUID/SGID across trust boundaries" issue remains, but is
largely theoretic. This is a rediscovery of CVE-2000-0992.
jmm: 3.9p1 thus marked as fixed version

Search for package or bug name: Reporting problems