CVE-2004-0371

NameCVE-2004-0371
DescriptionHeimdal 0.6.x before 0.6.1 and 0.5.x before 0.5.3 does not properly perform certain consistency checks for cross-realm requests, which allows remote attackers with control of a realm to impersonate others in the cross-realm trust path.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-476
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
heimdal (PTS)wheezy1.6~git20120403+dfsg1-2fixed
wheezy (security)1.6~git20120403+dfsg1-2+deb7u1fixed
jessie (security), jessie1.6~rc2+dfsg-9+deb8u1fixed
stretch (security), stretch7.1.0+dfsg-13+deb9u1fixed
buster, sid7.4.0.dfsg.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
heimdalsource(unstable)0.6.1-1medium
heimdalsourcewoody0.4e-7.woody.8.1mediumDSA-476

Search for package or bug name: Reporting problems