CVE-2004-0400

NameCVE-2004-0400
DescriptionStack-based buffer overflow in Exim 4 before 4.33, when the headers_check_syntax option is enabled, allows remote attackers to cause a denial of service and possibly execute arbitrary code during the header check.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-501, DSA-502
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
exim4 (PTS)wheezy4.80-7+deb7u3fixed
wheezy (security)4.80-7+deb7u5fixed
jessie (security), jessie4.84.2-2+deb8u4fixed
stretch (security), stretch4.89-2+deb9u1fixed
buster, sid4.89-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
eximsource(unstable)3.36-11high
eximsourcewoody3.35-1woody3highDSA-501
exim-tlssource(unstable)(unfixed)high
exim-tlssourcewoody3.35-3woody2highDSA-502
exim4source(unstable)4.33-1high

Search for package or bug name: Reporting problems