CVE-2004-0409

NameCVE-2004-0409
DescriptionStack-based buffer overflow in the Socks-5 proxy code for XChat 1.8.0 to 2.0.8, with socks5 traversal enabled, allows remote attackers to execute arbitrary code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-493
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xchat (PTS)wheezy2.8.8-7.1fixed
wheezy (security)2.8.8-7.1+deb7u1fixed
jessie2.8.8-7.3fixed
buster, sid2.8.8-11fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xchatsource(unstable)2.0.8-1high
xchatsourcewoody1.8.9-0woody3highDSA-493

Search for package or bug name: Reporting problems