CVE-2004-0417

NameCVE-2004-0417
DescriptionInteger overflow in the "Max-dotdot" CVS protocol command (serve_max_dotdot) for CVS 1.12.x through 1.12.8, and 1.11.x through 1.11.16, may allow remote attackers to cause a server crash, which could cause temporary data to remain undeleted and consume disk space.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-519
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cvs (PTS)wheezy2:1.12.13+real-9fixed
wheezy (security)2:1.12.13+real-9+deb7u1fixed
jessie2:1.12.13+real-15fixed
jessie (security)2:1.12.13+real-15+deb8u1fixed
stretch (security), stretch2:1.12.13+real-22+deb9u1fixed
buster, sid2:1.12.13+real-24fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cvssource(unstable)1:1.12.9-1medium
cvssourcewoody1.11.1p1debian-9woody7mediumDSA-519

Search for package or bug name: Reporting problems