CVE-2004-0418

NameCVE-2004-0418
Descriptionserve_notify in CVS 1.12.x through 1.12.8, and 1.11.x through 1.11.16, does not properly handle empty data lines, which may allow remote attackers to perform an "out-of-bounds" write for a single byte to execute arbitrary code or modify critical program data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-519
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cvs (PTS)wheezy2:1.12.13+real-9fixed
wheezy (security)2:1.12.13+real-9+deb7u1fixed
jessie2:1.12.13+real-15fixed
jessie (security)2:1.12.13+real-15+deb8u1fixed
stretch (security), stretch2:1.12.13+real-22+deb9u1fixed
buster, sid2:1.12.13+real-24fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cvssource(unstable)1:1.12.9-1high
cvssourcewoody1.11.1p1debian-9woody7highDSA-519

Search for package or bug name: Reporting problems