CVE-2004-0597

NameCVE-2004-0597
DescriptionMultiple buffer overflows in libpng 1.2.5 and earlier, as used in multiple products, allow remote attackers to execute arbitrary code via malformed PNG images in which (1) the png_handle_tRNS function does not properly validate the length of transparency chunk (tRNS) data, or the (2) png_handle_sBIT or (3) png_handle_hIST functions do not perform sufficient bounds checking.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-536
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libpng (PTS)wheezy, wheezy (security)1.2.49-1+deb7u2fixed
jessie1.2.50-2+deb8u3fixed
jessie (security)1.2.50-2+deb8u2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libpngsource(unstable)1.0.15-6high
libpngsourcewoody1.0.12-3.woody.7highDSA-536
libpng3source(unstable)1.2.5.0-7high
libpng3sourcewoody1.2.1-1.1.woody.7highDSA-536

Search for package or bug name: Reporting problems