CVE-2004-0599

NameCVE-2004-0599
DescriptionMultiple integer overflows in the (1) png_read_png in pngread.c or (2) png_handle_sPLT functions in pngrutil.c or (3) progressive display image reading capability in libpng 1.2.5 and earlier allow remote attackers to cause a denial of service (application crash) via a malformed PNG image.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-536, DSA-570-1, DSA-571-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libpng (PTS)squeeze, squeeze (security)1.2.44-1+squeeze4fixed
wheezy1.2.49-1fixed
stretch, jessie, sid1.2.50-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libpngsource(unstable)1.0.15-6medium
libpngsourcewoody1.0.12-3.woody.9mediumDSA-570-1
libpng3source(unstable)1.2.5.0-7medium
libpng3sourcewoody1.2.1-1.1.woody.9mediumDSA-571-1

Search for package or bug name: Reporting problems