CVE-2004-0755

NameCVE-2004-0755
DescriptionThe FileStore capability in CGI::Session for Ruby before 1.8.1, and possibly PStore, creates files with insecure permissions, which can allow local users to steal session information and hijack sessions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-537
NVD severitylow (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby1.8 (PTS)wheezy1.8.7.358-7.1+deb7u3fixed
wheezy (security)1.8.7.358-7.1+deb7u4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rubysource(unstable)(unfixed)low
rubysourcewoody1.6.7-3woody3lowDSA-537
ruby1.8source(unstable)1.8.1+1.8.2pre1-4low

Search for package or bug name: Reporting problems