CVE-2004-0768

NameCVE-2004-0768
Descriptionlibpng 1.2.5 and earlier does not properly calculate certain buffer offsets, which could allow remote attackers to execute arbitrary code via a buffer overflow attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-536
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libpng (PTS)wheezy, wheezy (security)1.2.49-1+deb7u2fixed
jessie1.2.50-2+deb8u3fixed
jessie (security)1.2.50-2+deb8u2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libpngsource(unstable)1.0.15-6high
libpngsourcewoody1.0.12-3.woody.7highDSA-536
libpng3source(unstable)1.2.5.0-7high
libpng3sourcewoody1.2.1-1.1.woody.7highDSA-536

Search for package or bug name: Reporting problems