CVE-2004-0777

NameCVE-2004-0777
DescriptionFormat string vulnerability in the auth_debug function in Courier-IMAP 1.6.0 through 2.2.1 and 3.x through 3.0.3, when login debugging (DEBUG_LOGIN) is enabled, allows remote attackers to execute arbitrary code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs266723

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
courier (PTS)stretch0.76.3-5+deb9u1fixed
sid, buster1.0.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
couriersource(unstable)0.45.6-1medium266723

Notes

0.45.6-1 is the first upload after the debug stuff rewrite
mentioned in the bug report.

Search for package or bug name: Reporting problems