CVE-2004-0782

NameCVE-2004-0782
DescriptionInteger overflow in pixbuf_create_from_xpm (io-xpm.c) in the XPM image decoder for gtk+ 2.4.4 (gtk2) and earlier, and gdk-pixbuf before 0.22, allows remote attackers to execute arbitrary code via certain n_col and cpp values that enable a heap-based buffer overflow. NOTE: this identifier is ONLY for gtk+. It was incorrectly referenced in an advisory for a different issue (CVE-2004-0687).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-546-1, DSA-549-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gdk-pixbuf (PTS)wheezy2.26.1-1+deb7u3fixed
wheezy (security)2.26.1-1+deb7u6fixed
jessie2.31.1-2+deb8u5fixed
jessie (security)2.31.1-2+deb8u6fixed
stretch (security), stretch2.36.5-2+deb9u1fixed
buster, sid2.36.11-1fixed
gtk+2.0 (PTS)wheezy2.24.10-2fixed
jessie2.24.25-3+deb8u2fixed
buster, sid, stretch2.24.31-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gdk-pixbufsource(unstable)0.22.0-7high
gdk-pixbufsourcewoody0.17.0-2woody2highDSA-546-1
gtk+2.0source(unstable)2.4.9-2high
gtk+2.0sourcewoody2.0.2-5woody2highDSA-549-1

Search for package or bug name: Reporting problems