CVE-2004-0802

NameCVE-2004-0802
DescriptionBuffer overflow in the BMP loader in imlib2 before 1.1.2 allows remote attackers to execute arbitrary code via a specially-crafted BMP image, a different vulnerability than CVE-2004-0817.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-552-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imlib2 (PTS)wheezy, wheezy (security)1.4.5-1+deb7u2fixed
jessie, jessie (security)1.4.6-2+deb8u2fixed
buster, sid, stretch1.4.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imlib2source(unstable)1.1.0-12.4medium
imlib2sourcewoody1.0.5-2woody1mediumDSA-552-1

Search for package or bug name: Reporting problems