CVE-2004-0803

NameCVE-2004-0803
DescriptionMultiple vulnerabilities in the RLE (run length encoding) decoders for libtiff 3.6.1 and earlier, related to buffer overflows and integer overflows, allow remote attackers to execute arbitrary code via TIFF files.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-567-1
NVD severityhigh (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kdegraphics (PTS)squeeze4:4.4.5-2fixed
tiff (PTS)squeeze (security), squeeze3.9.4-5+squeeze10fixed
squeeze (lts)3.9.4-5+squeeze11fixed
wheezy, wheezy (security)4.0.2-6+deb7u3fixed
jessie, sid4.0.3-12.1fixed
tiff3 (PTS)wheezy3.9.6-11fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kdegraphicssource(unstable)3.3.2-1high
tiffsource(unstable)3.6.1-2high
tiffsourcewoody3.5.5-6woody1highDSA-567-1
tiff3source(unstable)(not affected)

Notes

- tiff3 <not-affected> (fixed prior to initial upload)

Search for package or bug name: Reporting problems