CVE-2004-0884

NameCVE-2004-0884
DescriptionThe (1) libsasl and (2) libsasl2 libraries in Cyrus-SASL 2.1.18 and earlier trust the SASL_PATH environment variable to find all available SASL plug-ins, which allows local users to execute arbitrary code by modifying the SASL_PATH to point to malicious programs.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-563-3, DSA-568-1
NVD severityhigh (attack range: local)
Debian Bugs275431, 275432, 275553, 276865

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cyrus-sasl2 (PTS)wheezy2.1.25.dfsg1-6+deb7u1fixed
jessie (security), jessie2.1.26.dfsg1-13+deb8u1fixed
buster, sid, stretch2.1.27~101-g0780600+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cyrus-saslsource(unstable)(unfixed)high
cyrus-saslsourcewoody1.5.27-3.1woody5highDSA-563-3275432
cyrus-sasl-mitsourcewoody1.5.24-15woody3highDSA-568-1
cyrus-sasl2source(unstable)2.1.19-1.3high275431, 275432, 275553, 276865

Search for package or bug name: Reporting problems