CVE-2004-0885

NameCVE-2004-0885
DescriptionThe mod_ssl module in Apache 2.0.35 through 2.0.52, when using the "SSLCipherSuite" directive in directory or location context, allows remote clients to bypass intended restrictions by using any cipher suite that is allowed by the virtual host configuration.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)jessie2.4.10-10+deb8u12fixed
jessie (security)2.4.10-10+deb8u13fixed
stretch2.4.25-3+deb9u6fixed
stretch (security)2.4.25-3+deb9u4fixed
buster, sid2.4.38-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2source(unstable)2.0.52-2high
libapache-mod-sslsource(unstable)2.8.20-1high

Search for package or bug name: Reporting problems