CVE-2004-0914

NameCVE-2004-0914
DescriptionMultiple vulnerabilities in libXpm for 6.8.1 and earlier, as used in XFree86 and other packages, include (1) multiple integer overflows, (2) out-of-bounds memory accesses, (3) directory traversal, (4) shell metacharacter, (5) endless loops, and (6) memory leaks, which could allow remote attackers to obtain sensitive information, cause a denial of service (application crash), or execute arbitrary code via a certain XPM image file. NOTE: it is highly likely that this candidate will be SPLIT into other candidates in the future, per CVE's content decisions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-607-1
NVD severityhigh (attack range: remote)
Debian Bugs294099, 309143, 309819

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lesstif2 (PTS)wheezy1:0.95.2-1.1fixed
openmotif (PTS)wheezy/non-free2.3.3-8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lesstif1-1source(unstable)1:0.93.94-11.3high294099
lesstif2source(unstable)1:0.93.94-11.2high
openmotifsource(unstable)2.2.3-1.1medium309819
xfree86source(unstable)4.3.0.dfsg.1-14high309143
xfree86sourcewoody4.1.0-16woody5highDSA-607-1

Notes

Previous -9 fix had some issues of its own
lesstif1 and 2 have to be fixed separately
but lesstif2 did get fixed for this hole..
[sarge] - openmotif <no-dsa> (Non-free)

Search for package or bug name: Reporting problems