CVE-2004-0916

NameCVE-2004-0916
DescriptionDirectory traversal vulnerability in cabextract before 1.1 allows remote attackers to overwrite arbitrary files via a cabinet file containing .. (dot dot) sequences in a filename.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-574-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cabextract (PTS)wheezy1.4-3fixed
jessie1.4-5fixed
stretch1.6-1fixed
buster, sid1.6-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cabextractsource(unstable)1.1-1medium
cabextractsourcewoody0.2-2bmediumDSA-574-1

Search for package or bug name: Reporting problems