CVE-2004-0941

NameCVE-2004-0941
DescriptionMultiple buffer overflows in the gd graphics library (libgd) 2.0.21 and earlier may allow remote attackers to execute arbitrary code via malformed image files that trigger the overflows due to improper calls to the gdMalloc function, a different set of vulnerabilities than CVE-2004-0990.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-601-1, DSA-602-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgd2 (PTS)wheezy2.0.36~rc1~dfsg-6.1+deb7u2fixed
wheezy (security)2.0.36~rc1~dfsg-6.1+deb7u10fixed
jessie2.1.0-5+deb8u9fixed
jessie (security)2.1.0-5+deb8u11fixed
stretch (security), stretch2.2.4-2+deb9u2fixed
buster, sid2.2.5-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgdsource(unstable)1.8.4-36.1high
libgdsourcewoody1.8.4-17.woody4highDSA-601-1
libgd2source(unstable)2.0.33-1.1high
libgd2sourcewoody2.0.1-10woody2highDSA-602-1

Search for package or bug name: Reporting problems