CVE-2004-0947

NameCVE-2004-0947
DescriptionBuffer overflow in unarj before 2.63a-r2 allows remote attackers to execute arbitrary code via an arj archive that contains long filenames.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-652-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
arj (PTS)wheezy, wheezy (security)3.10.22-10+deb7u1fixed
jessie3.10.22-13fixed
stretch3.10.22-15fixed
buster, sid3.10.22-16fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
arjsource(unstable)(not affected)
unarjsourcewoody2.43-3woody1highDSA-652-1

Notes

see http://lwn.net/Alerts/110733/
- arj <not-affected> (sarge's unarj is from a different code base, probably not vulnerable)

Search for package or bug name: Reporting problems