CVE-2004-0975

NameCVE-2004-0975
DescriptionThe der_chop script in the openssl package in Trustix Secure Linux 1.5 through 2.1 and other operating systems allows local users to overwrite files via a symlink attack on temporary files.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-603-1
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssl (PTS)stretch1.1.0l-1~deb9u1fixed
stretch (security)1.1.0l-1~deb9u3fixed
buster1.1.1d-0+deb10u6fixed
buster (security)1.1.1d-0+deb10u7fixed
bullseye1.1.1k-1fixed
bullseye (security)1.1.1k-1+deb11u1fixed
bookworm, sid1.1.1l-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensslsourcewoody0.9.6c-2.woody.7DSA-603-1
opensslsource(unstable)0.9.7e-3

Notes

-1 claimed to include it, but it was missing

Search for package or bug name: Reporting problems