CVE-2004-0976

NameCVE-2004-0976
DescriptionMultiple scripts in the perl package in Trustix Secure Linux 1.5 through 2.1 and other operating systems allows local users to overwrite files via a symlink attack on temporary files.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-620-1
NVD severitylow (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
perl (PTS)wheezy5.14.2-21+deb7u3fixed
wheezy (security)5.14.2-21+deb7u5fixed
jessie5.20.2-3+deb8u8fixed
jessie (security)5.20.2-3+deb8u9fixed
stretch (security), stretch5.24.1-3+deb9u2fixed
buster, sid5.26.0-8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
perlsource(unstable)5.8.4-4low
perlsourcewoody5.6.1-8.8lowDSA-620-1

Search for package or bug name: Reporting problems