CVE-2004-0993

NameCVE-2004-0993
DescriptionBuffer overflow in hpsockd before 0.6 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-604-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
hpsockd (PTS)wheezy, buster, sid, jessie, stretch0.17fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
hpsockdsource(unstable)0.14high
hpsockdsourcewoody0.6.woody1highDSA-604-1

Search for package or bug name: Reporting problems